BGP Configurations and Verifications – Networking – 350-601 Study Guide

Example 1-10 shows SW9621-1 BGP feature enabling and BGP router configurations.

Example 1-10 BGP AS 65100 Creation Configuration

SW9621-1(config)#
feature bgp

SW9621-1(config)#
router bgp 65100

SW9621-1(config-router)#
router-id 1.1.1.1

SW9621-1(config-router)#
address-family ipv4 unicast

SW9621-1(config-router-af)#
network 192.168.1.0/24

SW9621-1(config-router)#
neighbor 2201:db1::2 remote-as 65100

SW9621-1(config-router-neighbor)#
address-family ipv6 unicast

SW9621-1(config-router)#
neighbor 10.10.10.2 remote-as 65100

SW9621-1(config-router-neighbor)#
address-family ipv4 unicast

SW9621-1(config-router-neighbor)#
address-family ipv4 multicast

SW9621-1(config-router)#
neighbor 10.10.10.6 remote-as 100

SW9621-1(config-router-neighbor)#
address-family ipv4 unicast

Example 1-11 shows SW9621-1 interface configurations.

Example 1-11 Interface Configurations

SW9621-1(config)#
interface loopback1

SW9621-1(config-if)#
ip address 192.168.1.1/24

SW9621-1(config)#
interface Ethernet2/1

SW9621-1(config-if)#
ip address 10.10.10.1/30

SW9621-1(config-if)#
no shutdown

SW9621-1(config)#
interface Ethernet2/2

SW9621-1(config-if)#
ip address 10.10.10.5/30

SW9621-1(config-if)#
no shutdown

Example 1-12 shows the SW9621-1 BGP neighbors and summary.

Example 1-12 BGP Verification

SW9621-1(config)#
show ip bgp summary


BGP summary information for VRF default, address family IPv4 Unicast
BGP router identifier 1.1.1.1, local AS number 65100
BGP table version is 14, IPv4 Unicast config peers 2, capable peers 2
3 network entries and 3 paths using 432 bytes of memory
BGP attribute entries [3/432], BGP AS path entries [1/6]
BGP community entries [0/0], BGP clusterlist entries [0/0]

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down
State/PfxRcd
10.10.10.2 4 65100 154 152 14 0 0 01:46:14
1
10.10.10.6 4 100 23 25 14 0 0 00:10:52
1
SW9621-1(config)#
show ip bgp

BGP routing table information for VRF default, address family IPv4 Unicast
BGP table version is 14, local router ID is 1.1.1.1
Status: s-suppressed, x-deleted, S-stale, d-dampened, h-history, *-valid,
>-best
Path type: i-internal, e-external, c-confed, l-local, a-aggregate, r-redist,
I-injected
Origin codes: i – IGP, e – EGP, ? – incomplete, | – multipath, & – backup

Network Next Hop Metric LocPrf Weight
Path
*>l192.168.1.0/24 0.0.0.0 100 32768
i
*>i192.168.2.0/24 10.10.10.2 100 0
i
*>e192.168.3.0/24 10.10.10.6 0
100 i

SW9621-1(config)#
show bgp all


BGP routing table information for VRF default, address family IPv4 Unicast
BGP table version is 14, local router ID is 1.1.1.1
Status: s-suppressed, x-deleted, S-stale, d-dampened, h-history, *-valid,
>-best
Path type: i-internal, e-external, c-confed, l-local, a-aggregate, r-redist,
I-injected
Origin codes: i – IGP, e – EGP, ? – incomplete, | – multipath, & – backup

Network Next Hop Metric LocPrf Weight Path
*>l192.168.1.0/24 0.0.0.0 100 32768
i
*>i192.168.2.0/24 10.10.10.2 100 0
i
*>e192.168.3.0/24 10.10.10.6 0
100 i
SW9621-1(config)#
show bgp sessions


Total peers 3, established peers 3
ASN 65100
VRF default, local ASN 65100
peers 3, established peers 3, local router-id 1.1.1.1
State: I-Idle, A-Active, O-Open, E-Established, C-Closing, S-Shutdown

Neighbor ASN Flaps LastUpDn|LastRead|LastWrit St Port(L/R)
Notif(S/R)
10.10.10.2 65100 3 01:48:28|00:00:23|00:00:20 E 14994/179
0/3
10.10.10.6 100 1 00:13:05|00:00:20|00:00:04 E 16596/179
0/1
2201:db1::2 65100 0 00:27:27|00:00:25|00:00:25 E 179/46276
0/0

SW9621-1(config)#
show ipv6 bgp sum


BGP summary information for VRF default, address family IPv6 Unicast
BGP router identifier 1.1.1.1, local AS number 65100
BGP table version is 3, IPv6 Unicast config peers 1, capable peers 1
0 network entries and 0 paths using 0 bytes of memory
BGP attribute entries [0/0], BGP AS path entries [0/0]
BGP community entries [0/0], BGP clusterlist entries [0/0]

Neighbor V AS MsgRcvd MsgSent Tbl Ver InQ OutQ Up/Down
State/PfxRcd
2201:db1::2 4 65100 33 34 3 0 0 00:27:59 0

Example 1-13 shows SW9621-2 full configurations and BGP neighbors.

Example 1-13 Router 2 Configuration and Verification (SW9621-2)

SW9621-2(config-router-neighbor)# show run bgp


feature bgp
router bgp 65100
router-id 2.2.2.2
address-family ipv4 unicast
network 192.168.2.0/24
neighbor 2201:db1::1 remote-as 65100
address-family ipv6 unicast
neighbor 10.10.10.1 remote-as 65100
address-family ipv4 unicast
address-family ipv4 multicast
SW9621-2(config-router-neighbor-af)#
show run int lo1

interface loopback1
ip address 192.168.2.1/24

SW9621-2(config-router-neighbor)#
show run int e2/1


interface Ethernet2/1
no switchport
mac-address 0000.0000.002f
ip address 10.10.10.2/30
ipv6 address 2201:db1::2/48
no shutdown

SW9621-2(config-router-neighbor)#
show bgp all

BGP routing table information for VRF default, address family IPv4 Unicast
BGP table version is 15, local router ID is 2.2.2.2
Status: s-suppressed, x-deleted, S-stale, d-dampened, h-history, *-valid,
>-best
Path type: i-internal, e-external, c-confed, l-local, a-aggregate, r-redist,
I-injected
Origin codes: i – IGP, e – EGP, ? – incomplete, | – multipath, & – backup

Network Next Hop Metric LocPrf Weight
Path
*>i192.168.1.0/24 10.10.10.1 100 0 i
*>l192.168.2.0/24 0.0.0.0 100 32768 i
i192.168.3.0/24 10.10.10.6 100 0
100 i

Example 1-14 shows SW9621-3 full configurations and BGP neighbors.

Example 1-14 Router 3 Configuration (SW9621-3)

SW9621-3(config-router-neighbor)#
show run bgp

feature bgp
router bgp 100
router-id 3.3.3.3
address-family ipv4 unicast
network 192.168.3.0/24
neighbor 10.10.10.5 remote-as 65100
address-family ipv4 unicast
weight 100

SW9621-3(config-router-neighbor-af)#
show run int lo

interface loopback10
ip address 192.168.3.1/24

SW9621-3(config-router-neighbor-af)#
show run int e2/1

interface Ethernet2/1
no switchport
mac-address 0000.0000.003f
ip address 10.10.10.6/30
no shutdown

SW9621-3#
show bgp all

BGP routing table information for VRF default, address family IPv4 Unicast
BGP table version is 11, local router ID is 3.3.3.3
Status: s-suppressed, x-deleted, S-stale, d-dampened, h-history, *-valid,
>-best
Path type: i-internal, e-external, c-confed, l-local, a-aggregate, r-redist,
I-injected
Origin codes: i – IGP, e – EGP, ? – incomplete, | – multipath, & – backup

Network Next Hop Metric LocPrf Weight
Path
*>e192.168.1.0/24 10.10.10.5 100
65100 i
*>e192.168.2.0/24 10.10.10.5 100
65100 i
*>l192.168.3.0/24 0.0.0.0 100 32768
i